Page 13 of 25 FirstFirst ... 39101112131415161723 ... LastLast
Results 361 to 390 of 736

Thread: E/X-Mag Microcontroller Programming (Atmel AT90S2313)

  1. #361
    Join Date
    Apr 2005
    Location
    a toda madre o un desmadr
    Posts
    5,078

    Exclamation hmm

    Quote Originally Posted by 11 Bravo
    Notice: The Norwegian prisoners were executed....er....I mean... shot while trying to escape this morning.
    .
    .

    let that be a notice to our german counterparts...and they were a national threat..we must protect the freedom of every american..and e/x mag owners..

  2. #362
    Join Date
    Jan 2006
    Posts
    497
    agreed.

  3. #363
    Join Date
    May 2005
    Location
    Florida
    Posts
    1,254
    Okay, I played with the Xmod today. It worked great and was very fast. I lowered the dwell and it is faster than 3.2 in semi. The gun and software worked flawlessly, just like advertised.
    I am sure with a little more tweaking of the settings it will get even better.

    This gets the 11 Bravo seal of approval..

  4. #364
    Join Date
    Apr 2005
    Location
    a toda madre o un desmadr
    Posts
    5,078

    Talking yeah

    man im so jealous,, i cant wait for mine...

  5. #365
    Join Date
    Jan 2006
    Posts
    497
    how do i get mine

  6. #366
    Join Date
    Nov 2004
    Location
    www.TheAlphaMag.com
    Posts
    842
    You can either:

    Purchase the programmer to flash your board yourself at a cost of $89 for the programmer, $60 for the cable, and whatever else you need (9v battery, etc),

    OR

    You can just be patient and wait about a month or two for the final versian to be released.

    "Ask not what your country can do for you; ask what you can do for your country." -JFK

  7. #367
    Join Date
    Jan 2006
    Posts
    497
    dude k ill wait....then i can just get somone to flash it for me??

  8. #368
    Join Date
    Aug 2005
    Location
    Milwaukee WI
    Posts
    365
    11Bravo can you please comment on how difficult the installation was with the STK500.

    If anyone else is interested in this Option I have 3 6-pin programming cables left. To purchasing one (for use with an STK500) please email me at pniedfeldt@wi.rr.com
    Last edited by LorneCash; 02-26-2006 at 10:10 PM.

  9. #369
    Join Date
    May 2005
    Location
    Florida
    Posts
    1,254
    [QUOTE=LorneCash]11Bravo can you please comment on how difficult the installation was with the STK500. QUOTE]

    It was very easy. The directions were right to the point and easy to follow.
    The only glitch was that I forgot to disable the tourney jumper and reprogramed the board a few times thinking that it hadnt gone thru correctly.
    Once I slapped my forehead and disabled the jumper everything worked fine.


    Used it again today - very awesome. Xmag at 20 bps =
    Last edited by 11 Bravo; 02-27-2006 at 12:10 AM.

  10. #370
    Join Date
    Aug 2005
    Location
    Milwaukee WI
    Posts
    365
    Quote Originally Posted by 11 Bravo
    The only glitch was that I forgot to disable the tourney jumper and reprogramed the board a few times thinking that it hadnt gone thru correctly.
    Once I slapped my forehead and disabled the jumper everything worked fine.
    Sorry man, I can't fix stupid... lol. I'll make sure and add that to the troubleshooting section though, that's the best I can do.

  11. #371
    I'll wait the "german solution", it's not an emergency for me.

    Lornecash, I really thank you for all that you do for us.

  12. #372
    Join Date
    Nov 2004
    Location
    UK
    Posts
    262
    wow! that was amazing! wish i could take vids

    i'll see if i can have a more detailed write up, but it doesn't look like i have anything more to say that hasn't already been said. i'll try testing this all the way to a completely drained battery to see what happens. altho, i'm not entirely sure about this one but i think my solenoid is failing to fire earlier into the battery (either that or my battery just wasn't fully charged when i started). You might also want to consider having the low batt message display when it can't fire the solenoid properly rather than just when the battery got really low (although, i make no claims to knowing how it actually detects the low battery).

    oh yea, i also didn't have much problems with the installation... other than somehow i got sold a dud battery (stay away from panasonic batts! ). oh and is it normal that the low batt message flashes while its connected to the programmer? (while the gun still has 3.2 installed. it dissappears once xmod is loaded. my xmag battery was not connected during the whole process)

    btw lornecash, you might get an email from me sometime soon about a custom boot message just as soon as i figure out what i want it to say

    EDIT: ok that was interesting. solenoid started not firing at all, low batt would keep coming on but would dissappear as soon as i pulled the trigger. i was in pratice mode tho (with the brightness waaaay up just to eat up the batt faster). in semi mode, the low batt message only appears when i try to push a button and not when i pull the trigger, and when it does come on, it wouldn't go away. then when i switch it off and on again, xmod doesn't load up at all. no damage to the chip or code at all tho, cos when i put in my spare batt everything loaded up like normal. i assume the low batt only comes on when the battery is almost completely dry which is when all the weird stuff happens.
    Last edited by Jotsy; 02-27-2006 at 09:40 AM.

  13. #373
    Join Date
    Aug 2005
    Location
    Milwaukee WI
    Posts
    365
    Quote Originally Posted by Jotsy
    when i put in my spare batt everything loaded up like normal. I assume the low batt only comes on when the battery is almost completely dry which is when all the weird stuff happens.
    The way the low battery message works is that it will come on when there is not enough battery to operate the microcontroller properly. The gun will stop shooting long before this happens because the solenoid requires much more battery power than the microcontroller.

    I wish I could change the low battery to be when the gun is not able to fire crrectly but I can't. The battery check is actually a hardware check and all I get is a 0 if it's ok and a 1 if it's bad. I can't change what voltage is says bad at. The moral of the story is if the low battery alert comes on it's really a dead battery alert rather than just low.

  14. #374
    Join Date
    Aug 2005
    Location
    Milwaukee WI
    Posts
    365
    Digikey had the STK500's back in stock, there are 56 units available at the time of this post. The price is $79.00 plus shipping.

    To find it go to www.digikey.com and type ATSTK500 in the search. Three items will be found you will want Digi-Key part number ATSTK500-ND

  15. #375
    Join Date
    Nov 2004
    Location
    UK
    Posts
    262
    oh ok. hmmm how did the original AGD 3.2 code do it?

  16. #376
    Join Date
    Jan 2006
    Posts
    497
    how much faster will this make my x-mag if i have this with the tuna blade??

  17. #377
    Join Date
    May 2005
    Location
    Florida
    Posts
    1,254
    ^^^^^^^^^^^So far I have had mine up to 20 bps. You can probably get up to 23 or 25. I figured 20 was fast enough and I am not going to play a game at 20 bps anyway.

    Note: that was with ramping.
    On semi in the practice setting I can reach 16 bps on the rof display.
    Last edited by 11 Bravo; 02-27-2006 at 03:42 PM.

  18. #378
    Join Date
    Feb 2005
    Location
    #1 Buck Adams fan
    Posts
    7,848
    Quote Originally Posted by 11 Bravo
    ^^^^^^^^^^^So far I have had mine up to 20 bps. You can probably get up to 23 or 25. I figured 20 was fast enough and I am not going to play a game at 20 bps anyway.

    FYI - with ramping too, and modes, wonderful, wonderful modes.


    I should make stickers for the sides of the guns "NOW WITH RAMPING!!"

  19. #379
    Join Date
    Jan 2006
    Posts
    497
    DUUUUDEEE do that good idea
    ull make a fortune for the "XMODERS" dude ill buy one...so whats the highest you can set it to?

  20. #380
    Join Date
    May 2005
    Location
    Florida
    Posts
    1,254
    Quote Originally Posted by sean33
    DUUUUDEEE do that good idea
    ull make a fortune for the "XMODERS" dude ill buy one...so whats the highest you can set it to?
    31 bps, but your gun will explode if you set it to that #.
    From what I hear 26 bps is the max for an E/X Mag.

  21. #381
    Join Date
    Aug 2005
    Location
    Milwaukee WI
    Posts
    365
    the max ROF is 31, the gun can shoot that fast if the dwell is set correctly and the input pressure is just below 3000psi. One of my first BETA testers verified this with a Q-Loader by hooking his gun directly to a scuba tank at 2800psi. However, If your dwell is set to high or you hold that rate of fire for an extended period of time it is possible to fry your solenoid. Also if the input pressure is not high enough you will destroy your sear. So be warned, I let the ROF stay that high mainly for PR-T mode so that the ROF would not limit you when you are trying to see how fast you can pull with the solenoid OFF. With a normal HPA tank that has a fixed output pressure of 800-1000psi you should not set the ROF above 20bps.

  22. #382
    Join Date
    Jan 2006
    Posts
    497
    fast enough for me...put me on the list for the program when it comes out.. i got a 100 dollars saved up for this and i cant wait

  23. #383
    Join Date
    Jan 2005
    Location
    Northern VA
    Posts
    1,100
    LorneCash: Hows it going? I've been on the preorder list at TAGsportz.com for alongtime now. Just wondering, If I buy the programmer could I load the software on a couple of my emags?

  24. #384
    Join Date
    Jan 2006
    Posts
    497
    ummm are you trying to say that is it possible to out the program on your e-mag..well if so i think you can..

  25. #385
    Join Date
    Feb 2003
    Location
    South
    Posts
    177
    Lorne,

    Have you received the German programmer as yet?

    I may have a line on the AVRISP (not MK2). If I can get them I'll let you know how many.

    Thanks for your efforts!

  26. #386
    Join Date
    Sep 2002
    Location
    Boston
    Posts
    444
    Quote Originally Posted by 11 Bravo
    31 bps, but your gun will explode if you set it to that #.
    From what I hear 26 bps is the max for an E/X Mag.
    If you fire it at 31 bps then you'd explode from the woody that won't quit.
    Forest Gump of paintball

  27. #387
    Join Date
    Jan 2006
    Posts
    497
    hahahahah...damn no ****.....

  28. #388
    Join Date
    Aug 2005
    Location
    Milwaukee WI
    Posts
    365
    No word on the ICprog yet. It was shipped on 2-19-06 so it should be comming any day now. Be sure, the instant I get my hands on it I will attempt to upload my software with it and report with a post here as to how it worked.

    If there are AVRISP's out there they work great. That's what I use. I'm sure there would be someone who could use them.

  29. #389
    Join Date
    Nov 2000
    Location
    South Africa
    Posts
    99
    Hey Lornecash

    Not getting a reply on my email, any luck sending the programmer to South Africa. I am all payed up for the ATSTK500. Just need some kinda clue if its on the way over here yet.


    dont forget about africa we are starving for this software and thats not a ninja its a black man in a balaklava!

  30. #390
    Join Date
    May 2005
    Location
    Florida
    Posts
    1,254
    I just noticed that the Xmod software is listed over on www.Xmagworld.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •