Results 1 to 8 of 8

Thread: Volume but no Pressure

Hybrid View

  1. #1
    Join Date
    Aug 2006
    Location
    port st. lousey fl origin
    Posts
    2,840

    Volume but no Pressure

    like it says volume but no psi , I removed & cleaned & checked o-ring on the #3 & #12 back check valves
    do the cylinders need to be in a certain orientation ( holes top & bottom ?)
    Ideas ?

  2. #2
    Join Date
    Oct 2000
    Location
    Chicago
    Posts
    5,956
    Does it register the 85 psi on the output? With nothing on the output does air blow out of it when the pistons are all the way out of the cylinders?

    Tom

  3. #3
    Join Date
    Aug 2006
    Location
    port st. lousey fl origin
    Posts
    2,840
    Sometimes I need to remember KISS ( keep it simple stupid ) , When checking for the 85 psi through the compressor I found that both my QD's were leaking , replace the o-rings & wala it works again , the leaks were small enough I couldn't hear them when the compressor was running , but big enough to lose pressure

  4. #4
    Join Date
    Oct 2000
    Location
    Chicago
    Posts
    5,956
    Yes that's a problem with such a low volume compressor. One tiny leak can ruin your day.

    In general it's almost impossible to have it pump nothing at all, because both cylinders have to go bad at once.

    Tom

  5. #5
    Join Date
    Aug 2006
    Location
    port st. lousey fl origin
    Posts
    2,840
    Thank you for the quick response , it's very nice when you can get good fast customer support
    I'm interested in buying a couple of Shoebox stickers , did you have any extras made ?

  6. #6
    Join Date
    Oct 2000
    Location
    Chicago
    Posts
    5,956
    Yes we have stickers. PM my wife and let her know and we can mail some out.

    Tom

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •