Results 1 to 5 of 5

Thread: Grease in vent

Hybrid View

  1. #1

    Grease in vent...anybody there

    I had trouble with the vent rod not working so I used my large Tank vent until I could take a look today.
    I found a wad of lithium grease when I pulled the vent rod.Does this mean I have to pull the air block and clean it thoroughly? How did the grease get past the pump seals? Any suggestions?
    Last edited by marauder25; 09-21-2010 at 03:42 PM. Reason: lonely

  2. #2
    Join Date
    Aug 2009
    Location
    Hot Florida
    Posts
    35
    Quote Originally Posted by marauder25
    I had trouble with the vent rod not working so I used my large Tank vent until I could take a look today.
    I found a wad of lithium grease when I pulled the vent rod.Does this mean I have to pull the air block and clean it thoroughly? How did the grease get past the pump seals? Any suggestions?

    Not to thread jack - but keeping similar issue together.

    I'm just now at the same thing my friend. After filling 8 tanks, my bleed is not working.
    I removed mine and didn't see any grease though. I lost almost 1/2 of a fill before I could get it to bleed. I unscrewed it in and out and in and out, till finally it caught, and rushed out properly. (before that it was really slow and drained the tank) Then the next tank it was ok - then the one after, it was not bleeding again.

    So I too am not sure what would cause this issue. I've read another post on this as well. It seems Tom may have a redesigned one we can get.

    Tom - do we PM you for a fix? or ShoeBox Tech?

    Thanks


    RoB

  3. #3
    Mine started having trouble the same way but I let it go for a week.I finally found some time to look at it and was surprised to see grease.Shouldn't be that hard to fix.This machine is easy to work on!

  4. #4
    Join Date
    Aug 2009
    Location
    Hot Florida
    Posts
    35
    Quote Originally Posted by marauder25
    Mine started having trouble the same way but I let it go for a week.I finally found some time to look at it and was surprised to see grease.Shouldn't be that hard to fix.This machine is easy to work on!

    I agree - I even tried to clean it out by blowing some input air through it (with the unit off and the arms fully extended) and air comes out the bleed hole..... but under pressure from the 68/4500 tank it wouldn't bleed except real slow, thus resulting in loosing pressure from my fresh fill. Strange.......

  5. #5
    Join Date
    Aug 2009
    Location
    Hot Florida
    Posts
    35
    I just got through PM'ing AGD my address to ship me a new Vent Rod.....



    .

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •