Results 1 to 6 of 6

Thread: Safety not working on CF Frame

  1. #1
    Join Date
    Nov 2009
    Location
    Manch Vegas, NH
    Posts
    648

    Safety not working on CF Frame

    I'm thinking this is an easy fix but before I take the safety apart I'd figure I'd ask here and save myself some time and steps.

    The safety on one of my carbon frames for a classic mag does not work. If I engage the safety I can still pull the trigger and it will fire the marker. Should I be looking to manipulate the safety rod itself and turn it so it catches the trigger which I would guess is the issue, or should I be looking at the trigger itself?

    I'm assuming if I remove the screw, spring, and bearing I will be able to twist the safety so it will catch? Or can I just remove the trigger and twist it while it is still intact? Anyone ever come across this issue? Thanks in advance.

  2. #2
    Join Date
    Oct 2006
    Location
    Houston, TX
    Posts
    3,194
    The 'fire' position of the safety plunger is the recess. The 'safe' position is the full plunger side. if the trigger is moving with the safety on (and off), I would expect that the trigger arm (on the back of the trigger) is broken or bent, unless some one has altered the plunger.

    If you take the safety out (the easier part), you should see the trigger arm come up into the hole when the trigger is back.

  3. #3
    Join Date
    Jan 2002
    Location
    Halifax, N.S., Canada
    Posts
    7,392
    The other option is that the trigger rod is too long. When the trigger is held against the safety, the back of the trigger should not hit the trigger rod. If it does, you should shorten the trigger rod.
    Except for the Automag in front, its usually the man behind the equipment that counts.

  4. #4
    Join Date
    Nov 2009
    Location
    Manch Vegas, NH
    Posts
    648
    Thanks guys, I'm hoping to get to this as soon as I get a the right size Allen wrench.

  5. #5
    Join Date
    Oct 2004
    Location
    Sebring, Florida
    Posts
    725
    To remove the safety you need a .050 allen wrench.
    I took the road least traveled...now where the hell am I ?

  6. #6
    Join Date
    Nov 2009
    Location
    Manch Vegas, NH
    Posts
    648
    Yeah, I found one. I swapped out triggers with another frame because it looked like it had excessive wear but that did not fix the issue, safety assembly is next once I find some time.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •