Page 1 of 2 12 LastLast
Results 1 to 30 of 46

Thread: Definite manufacturing issue with 2k9 mag

  1. #1

    Definite manufacturing issue with 2k9 mag

    Trying to get to the bottom of my 2k9 issue of not being able to get it up to a proper velocity, I decided to make a quick measurement.
    And they're is definitely a manufacturing prolblem.
    I measured inside the body from whe the valve ring in a regular mag body is, to whe the field screw goes. It was about 2 3/4 inches.
    With the 2k9 it's 3 inches.
    Thats a huge difference with the small tolerances Automags work under.

    Can anyone here with a 2k9 and a standard mag, checkmy measurements.
    If those with proper functioning 2k9's report different numbers then I can only surmise that some of these we not milled correctly.

  2. #2
    Join Date
    Sep 2008
    Location
    Ohio
    Posts
    4,619
    Measured a ULE and MiniMag body, both came in at about 2 7/8" to the front of the FS hole. Measured my MM2K9 without the insert and came in around 2 15/16, With the insert it is closer to 2 3/4, but probably because there is a lip on the insert keeping the tape measure from going in the extra 1/16 of an inch. I chrono fine. 285/290 all day long.

  3. #3
    Quote Originally Posted by OPBN
    Measured a ULE and MiniMag body, both came in at about 2 7/8" to the front of the FS hole. Measured my MM2K9 without the insert and came in around 2 15/16, With the insert it is closer to 2 3/4, but probably because there is a lip on the insert keeping the tape measure from going in the extra 1/16 of an inch. I chrono fine. 285/290 all day long.
    Mine is 3" with the insert.

  4. #4
    Join Date
    Sep 2008
    Location
    Ohio
    Posts
    4,619
    Just so we are on the same page, I am using a tape measure that just fits inside of the body. I am sliding it in until it hits something. In this case it's the lip from the insert.

  5. #5
    Rechecked my measurements,also using a tape measure.
    I am measuring from where the spring will hit the insert on the 2k9, and the metal insert on the ule body.

    The ULE ring to the FS is 3 1/2 "
    The 2k9 ring to the FS is 3"

  6. #6
    OPBN, when you look into the breach, what do you estimate the thickness of aluminum from the insert to where the removable breach is? Mine is about a 1/4" of aluminum.

  7. #7
    Join Date
    Sep 2008
    Location
    Ohio
    Posts
    4,619
    Quote Originally Posted by Henchman
    Rechecked my measurements,also using a tape measure.
    I am measuring from where the spring will hit the insert on the 2k9, and the metal insert on the ule body.

    The ULE ring to the FS is 3 1/2 "
    The 2k9 ring to the FS is 3"
    Ive measured 3 seperate bodies and all of them are 2 7/8 to the front of the FS hole. If you are getting 3 1/2" something is wrong. The spring sits on the inside of the insert, my tape measure will not fit inside the insert, so I am measuring from the lip. Before you were saying the MM2k9 was longer, now you are saying its shorter?

  8. #8
    Quote Originally Posted by OPBN
    Ive measured 3 seperate bodies and all of them are 2 7/8 to the front of the FS hole. If you are getting 3 1/2" something is wrong. The spring sits on the inside of the insert, my tape measure will not fit inside the insert, so I am measuring from the lip. Before you were saying the MM2k9 was longer, now you are saying its shorter?
    Im sure my tape measure is a little off.
    The big issue is the discrepency between the two different bodies, using the same tape measure.

    Coudl you look down teh feedneck, and see rough how thick teh aluminum is where teh insert sits against. I have a sneaky suspicion that some offense bodies were not milled down far enough inside. Causing some of them to not work properly, because there is too much pressure because the bolt can not slide in far enough.

  9. #9
    Join Date
    Dec 2006
    Posts
    1,644
    With ring:


    Without ring:


    I have yet to be able to get mine over 260 fps.

    *EDIT*
    Here is a ULE body on a Noxious rail:


    I have no issues adjusting upwards of 300 fps with this.

    Anyone have a good set of calipers to measure the ID of the MM2k9 and compare with another body?

    *EDIT2*
    Found my calipers and measured 6 times apiece. only measured right at the entrance of the body, not inside.

    ULE= 1.0080, 1.0000, 1.0035, 1.0070, 1.0090, 1.0055 for an avg of 1.0055

    MM2K9= 1.0020, 1.0030, .9990, .9945, .9990, 1.0000 for an avg of .9996

    Curious if anyone found any difference with theirs. Incidentally, the OD on the widest portion of my L10 bolts are .9770.
    Last edited by zondo; 06-06-2012 at 07:25 PM.

  10. #10
    Join Date
    Jan 2001
    Location
    Cottonwood, Az.
    Posts
    5,771
    Not sure if this will help you guys, but this is right out of AGD's sluggo body file.



    The measurement is from the center of the rear hole to the face of the body where the ring sits. (Not to the face of the ring, ring measures 0.0600" thick)

    Just measured my MM2k9 and my Rogue Factor Sluggo, neither have been tested so these are just base numbers.

    RF Sluggo 2.860"
    MM2K9 3.115"

    Measured same as the cad above without ring.

    If I can get the retaining ring out of my ULE I will post that measurement too.
    Last edited by luke; 06-06-2012 at 09:37 PM.

  11. #11
    the ptp mag seems to have some real issues with the 2k9 i thought ptp was fixing them? best thing is probably have xmagteror cut u a new body

  12. #12
    Quote Originally Posted by RT Lover
    the ptp mag seems to have some real issues with the 2k9 i thought ptp was fixing them? best thing is probably have xmagteror cut u a new body
    I think using a lathe to correct it, would most certainly be easier, and cheaper.

  13. #13
    true if you can! Hope it works out man! maybe u can fix others also?

  14. #14
    Join Date
    Sep 2008
    Location
    Ohio
    Posts
    4,619
    My measurements on my AGD bodies are off. I realized from looking through the sear slot that they are not going fully forward due to my tape measure being too wide. Regardless, my measurements look the same as Zondos on my PTP and I can chrono fine.... Wonder why the difference?


    *Edit - I found a thinner tape measure, and my ULE measures around 3 1/16 to the front of the hole with the ring and clip in. My MM2K9 measurements are still 2 7/8 with the insert and 3" without. Still looks very similiar to what Zondo is showing.

    I tried measuring my ID and came up with measurements ranging from .9895 to .9760. The only part I can get a good measurement on is the side to side and it comes in at around .9880.

    Also, I measured the L10 bolt that I am using and mine comes in at .9810.

    Henchman, maybe someone else can get you the inner breach thickness. Honestly I am terrible at guestimating and hate disassembling this thing. The only way to get a good measurement is to take it totally apart and actually measure it.

    Frizzle Fry mentioned that his steel washers had to be pressed in while mine and it seems others just dropped in. However, he has not mentioned any issue with velocity and neither have I.
    Last edited by OPBN; 06-07-2012 at 09:11 AM.

  15. #15
    I am sending it to ptp, and they are going to check it out.
    I'll let everyone know the outcome.

    Mark

  16. #16
    Join Date
    Dec 2006
    Posts
    1,644
    Quote Originally Posted by Henchman
    I am sending it to ptp, and they are going to check it out.
    I'll let everyone know the outcome.

    Mark
    Meaning Tracy or Russel?

  17. #17
    Quote Originally Posted by zondo
    Meaning Tracy or Russel?
    Forrest.

  18. #18
    Join Date
    Dec 2006
    Posts
    1,644
    Quote Originally Posted by Henchman
    Forrest.
    Touche...

  19. #19
    Join Date
    Oct 2002
    Location
    Sanford, FL
    Posts
    243
    Henchman, do you have a final resolution or fix on your velocity issues? I have the same problem, I am still unable to get my MM 2K9 up above 250 fps. Same valve (ReTro with L10) shoots above 300 in an ULE body.

    I measured without the stainless steel washer, as shown above, and from the lip to the FS screw is 3.1 inches.

  20. #20
    Quote Originally Posted by DoubleDutch
    Henchman, do you have a final resolution or fix on your velocity issues? I have the same problem, I am still unable to get my MM 2K9 up above 250 fps. Same valve (ReTro with L10) shoots above 300 in an ULE body.

    I measured without the stainless steel washer, as shown above, and from the lip to the FS screw is 3.1 inches.
    Still waiting to hear back from ptp

  21. #21
    Join Date
    Sep 2009
    Location
    Toronto, Canada
    Posts
    45

    PTP 2k9 issues

    I have a specs issue also. The body I have has rear diameter that is too small to fit a classic valve. An x-valve fits but only just and causes sever bolt stick issues that I dont get using my ULE body. Also contacted PTP and awaiting response.

  22. #22
    Join Date
    Dec 2006
    Posts
    1,644
    Heard from Forest yet?

  23. #23
    Quote Originally Posted by zondo
    Heard from Forest yet?
    Yes. He's been working on it, but has been swamped with other work as well. But should be getting to the bottom of it in the next week or so.

  24. #24
    Keep on them. They have been "swamped" for years now.

    They do have extra bodies that Tracy is trying to sell you could ask them to replace the defective body.

    Oh & while you have Forest's ear, ask him about the shirts.

  25. #25
    Join Date
    Jul 2008
    Location
    Massachusetts
    Posts
    551
    Quote Originally Posted by WUNDERWAFFEN
    Oh & while you have Forest's ear, ask him about the shirts.
    I feel like some people around here bought T-shirts so they could get a free gun or something.

  26. #26
    Join Date
    Apr 2010
    Location
    triple mag shop.
    Posts
    3,123
    when i had any issues, which of course were minor compared to what you guys are dealing with, someone was always there more then happy to help.

  27. #27
    Join Date
    Dec 2006
    Posts
    1,644
    Any update on this? I'm thinking Forrest had to have some free time by now...

  28. #28
    wow....im scared to use mine......i havent even set it up......much less sent it off......ill keep an eye on this one......

    what sucks they did a good job on the look and feel of this gun but with so many issues makes ya wanna say "come on man!!!"

  29. #29
    Join Date
    Jun 2003
    Location
    Nashville, TN
    Posts
    1,145
    Yeah, I'm glad I stayed out of this when they brought it out. I thought, 'thats neat', but I've never been a big Micromag fan. I still don't know how a reputable company that made mag parts/acessories for YEARS could screw this up so bad.

  30. #30
    Join Date
    Feb 2005
    Location
    #1 Buck Adams fan
    Posts
    7,856
    (Dont look too closely at the deten't positions either)



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •