Results 1 to 6 of 6

Thread: CP On/Off question

  1. #1
    Join Date
    Sep 2008
    Location
    Ohio
    Posts
    4,326

    CP On/Off question

    I got in an older CP On/Off recently. I noticed that it is fairly hard to turn on and off. Is this normal? I I have some other on/offs that I have had this issue with, but never a CP.

    Also, it does not vent. Again, all my other CP on/offs vent. Are the two issues related?

    I can get a pic of the on/off if necessary.

  2. #2
    The older style CP on/offs seem harder to turn on and off, but even they vent in my experience. I've heard that there have been quite a few CP on/off asa knockoffs out and about, so it may be that you got something that's not genuine. Did you buy it new or used?

  3. #3
    Join Date
    Sep 2008
    Location
    Ohio
    Posts
    4,326
    Used. It's an older rail mount with a knurled on/off knob.

  4. #4
    Join Date
    Nov 2009
    Location
    Manch Vegas, NH
    Posts
    549
    Did you pick this up from me by chance? Is this the one that had a weird brass insert with holes instead of an hourglass insert?

  5. #5
    Join Date
    Nov 2009
    Location
    Manch Vegas, NH
    Posts
    549
    Quote Originally Posted by OPBN
    Used. It's an older rail mount with a knurled on/off knob.
    Nevermind, the one I sold recently was a direct mount.

  6. #6
    Join Date
    Sep 2008
    Location
    Ohio
    Posts
    4,326
    No. Insides of this one look very different from any that I have seen before. However, this isnt the first on/off that I have had thats been this way. I have an old unimount one that I think was made by invert that is difficult to get on and off as well.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •