Results 1 to 10 of 10

Thread: Never tuned a Mag before. Help me please.

  1. #1
    Join Date
    Feb 2009
    Location
    bluffton, south carolina (near hilton head for all you ohio-ans lol)
    Posts
    308

    Never tuned a Mag before. Help me please.

    Yo. I have a ULE Xvalved mag. I want to play paintball with it- but its god awful need of a tuning and dont know how to do it. I have a 68/3000 tank right now idk what the output is but my gun is rt-ing like a mad man when i barely touch the trigger (it may have a ULT in it) when i stop it takes a second for the valved to reset.... HELP thank you oh so helpful people.

  2. #2
    Join Date
    Oct 2004
    Location
    Daniel Island, SC
    Posts
    1,348
    im sure if you end up heading to paintball charleston geoff can get it set up pretty quick. your best bet would be to call and ask.

  3. #3
    Join Date
    Jun 2009
    Location
    Kentucky
    Posts
    4,140
    If you have shims in your on/off, you have a ULT. Pull all your ULT shim out and see how it goes from there, then add shims to taste.

    Send some oil through the marker too. That usually fixes most issues.

  4. #4
    Join Date
    Feb 2009
    Location
    bluffton, south carolina (near hilton head for all you ohio-ans lol)
    Posts
    308
    thanks everyone:

    I did check them out and those helped considerably. I found out that I am in need of an RT parts kit so I ordered one I ordered a couple things when I took it apart I found out that the I need a few things. Something else I was thinking after reading off of the AGD store was that my on/off may be the wrong one becuase this Xvalve was originally on an RT Pro. Also when i took it apart the reg springs were coated in som nasty thick grease. so i cleaned all the inards as best I could. and the I think i lost a reg seat o-ring when i took it apart and also i found one was cracked.

    Pinky:
    Ive I cant get it working I may go up there for a day with a friend a play a bit i will definately hit you up if i go though. thanks!!

    Ando:

    Thanks i will do that, I will have pictures up tonight
    she is one sexy gun

    thanks everyone

  5. #5
    Join Date
    Jan 2002
    Location
    Halifax, N.S., Canada
    Posts
    7,235
    The grease on the springs is only to keep them from rusting. Clean it off and reapply some good quality grease.

    The on-off pin should be 0.750" for your gun.
    Except for the Automag in front, its usually the man behind the equipment that counts.

  6. #6
    Join Date
    Feb 2009
    Location
    bluffton, south carolina (near hilton head for all you ohio-ans lol)
    Posts
    308
    I Think it has a ULT trigger pull kit on it- is it possible to put the ULT on a Classic 68 valve, and use the on off from the classic on my x valve?

  7. #7
    Join Date
    Jun 2009
    Location
    Kentucky
    Posts
    4,140
    No...it is not.

  8. #8
    Join Date
    Jan 2002
    Location
    Halifax, N.S., Canada
    Posts
    7,235
    The ULT doesn't work well on a classic valve without a lot of tweaking. The classic on-off assembly will work on an X-valve, but the trigger will be about 2 times more than with a standard retro valve on-off assembly. The classic on-off assembly will allow you to test the operation of the valve though.

  9. #9
    Join Date
    Jun 2009
    Location
    Kentucky
    Posts
    4,140
    Really? I've tried a classic in a X before and couldn't get it to work.

  10. #10
    Join Date
    Jan 2002
    Location
    Halifax, N.S., Canada
    Posts
    7,235
    Quote Originally Posted by Ando
    Really? I've tried a classic in a X before and couldn't get it to work.
    Yeah, the classic pin is 0.750" and the whole assembly fits the same diameter on-off hole. Just like the retro on-off assembly fits and works in a classic valve, the classic on-off assembly fits and works in a retro/X valve.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •