Results 1 to 10 of 10

Thread: Sear question, re: rapid firing and a ULE x-valve marker

  1. #1

    Sear question, re: rapid firing and a ULE x-valve marker

    (I have tried searching, but I think I'm more confused than before)
    So I have a question, which I'm gonna ask in two different ways:

    Abridged version:
    What type is the sear that comes with the Tac-One from the factory?

    Detailed version:
    I had originally purchased a Tac-One directly from AGD. Later, I decided I like carbon fiber, so I got rid of the Tac-One body, and got a ULE body that has since been milled and reworked with a carbon fiber sleeve. I also swapped in a ULT kit as well.
    After messing around with the idea of putting a Z-grip on it and getting an RT Pro rail and a classic rail, I decided it wasn't worth the time or money (at the time) to get the Z-grip to work properly with my marker. So I put the Z-grip back on the marker I bought in order to get it, and sold it. The marker left working like a charm.
    HOWEVER, I must have swapped out the sear somehow, because my marker isn't working like it should. Currently, dry-firing it makes it shoot full auto, for a 3 to 5 shot rapid burst. With paint, the marker will shoot once, and continues to whoosh air out. I checked and oiled everything, but it still does the same thing. I did notice that the back end/block of the sear (the part that contacts the on/off on the ULT in the X-valve) doesn't fit through the back hole of the carbon fiber sleeve. The thing is, I'm pretty confident it used to, because the marker worked like a charm before I messed with the grips and stuff. I know I moved the sear from rail to rail when working on this project, so I'm guessing this is the only other thing I can't fix that is causing the problem.
    So...is there anything else I can check? What is the sear style that would fit my ULE rail that would have a smaller back block that would fit through the back hole of the carbon fiber sleeve so that my marker can fire?

  2. #2
    Join Date
    Sep 2008
    Location
    Ohio
    Posts
    4,590
    RT Pro and Tac Ones both came with RTP sears. Simply put, if the rail you are using is an RTP or Tac One rail, you should have an RTP sear. If you have AM/MM rail, you should have an AM/MM sear. With that said, there are really no differences between the two sears other than the size of the hole that the sear axle goes through and that the RTP has a bushing on it. But each is specific to its designated rail.

    One thing to double check is to see if the CF sleeve has shifted. Sometimes when assembling/disassembling the body shifts. Make sure its properly aligned.

  3. #3
    Join Date
    Oct 2004
    Location
    Sebring, Florida
    Posts
    687
    I had a similar problem when I built a classic rt years ago. I just took a small round file(chiansaw file) and slightly elongated the hole in the back so that the sear would fully engage the on/off pin.My problem was that when I aired it up the on/off would leak alittle but wouldn't shoot because the small hole wouldn't let the sear disengage the bolt. Welcome to the sometimes twitchy world of AutoMags, I love em!!!
    I took the road least traveled...now where the hell am I ?

  4. #4
    Join Date
    Jun 2009
    Location
    Kentucky
    Posts
    4,146
    How many shims you have in your ULT? Pull a few out

  5. #5
    Join Date
    Oct 2011
    Location
    Sunny, England
    Posts
    344
    the lug on the back of the sear can be a different a thickness on diffent types of sears
    not sure if thats your problem


  6. #6
    Join Date
    Sep 2008
    Location
    Ohio
    Posts
    4,590
    Unless the body is out of spec there is no reason the sear shouldn't fit through the body.

  7. #7
    That's what I was thinking, was the lug on the back of the sear may have come in a smaller size. The carbon fiber body may have a smaller hole for the lug to go through. But, the original sear I had worked just fine with the smaller hole that is in the carbon fiber body. Somehow, through the swapping, the sear I have now doesn't fit.

    Anyone out there with a classic style sear?? Like in renie's picture??

  8. #8
    Join Date
    Sep 2008
    Location
    Ohio
    Posts
    4,590
    Quote Originally Posted by bigandugly
    That's what I was thinking, was the lug on the back of the sear may have come in a smaller size. The carbon fiber body may have a smaller hole for the lug to go through. But, the original sear I had worked just fine with the smaller hole that is in the carbon fiber body. Somehow, through the swapping, the sear I have now doesn't fit.

    Anyone out there with a classic style sear?? Like in renie's picture??
    A classic sear will not work if you are using an RT or Tac rail. Check the size of the hole against a stock body and see if there is any difference. I have swapped rails and bodies around multiple times and never run into an issue with a sear not working with a certain body. The hole in the CF could have been drilled out of spec.

  9. #9
    Join Date
    Jan 2001
    Location
    Cottonwood, Az.
    Posts
    5,781
    Quote Originally Posted by OPBN View Post
    there are really no differences between the two sears other than the size of the hole that the sear axle goes through and that the RTP has a bushing on it.
    And the length of the sear leg. The RTP sear "leg" is longer.

  10. #10
    Join Date
    Sep 2008
    Location
    Ohio
    Posts
    4,590
    Quote Originally Posted by luke View Post
    And the length of the sear leg. The RTP sear "leg" is longer.
    Ok, so there are some differences, but on a body that is milled to spec, there should be no functional difference. As long as the correct rail is being used any body should work with either sear. Sheez...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •