Results 1 to 23 of 23

Thread: classic valve wont fire?

Hybrid View

  1. #1
    Join Date
    Jan 2002
    Location
    southern IL
    Posts
    1,886

    classic valve wont fire?

    OK. I've been trying to get my wife's gun all setup and ready for Saturday. Issue after issue. Got my rt tuned up and working great even after its long hibernation. Not for the far newer gun. Bought a minimag, IFrame, and screw in 850psi output hpa tank. First I fill the tank and the nipple leaks. Drain. the tank and pull the nipple. Oring pinched. Replaced it with an automag on off oring. Works like a champ now. Then get air on the gun. Trigger pull feels stiffer than I remember. But its been a while. Pull the trigger. And nothing. Just springs back out. I've checked the sear pin and it is adjusted correct. It has an rt on off in it. And some odd after marked velocity adjust thumb screw. I hooked my adjustable tank to the gun with no luck. All orings and everything in the air valve are clean as can be. Only things I'm down to is..... bolt lodged somehow? But no air seeps down the barrel with trigger pulled. Not enough psi getting through the classic regulator for some reason? Anything I'm missing?

  2. #2
    Join Date
    Jan 2008
    Location
    central pa
    Posts
    64
    Does it fire with the barrel out, maybe severe bolt stick/ barrel interference. Power tube oring not lubed enough? Or level 10 carrier too tight? Just throwing ideas out there.... Good luck!

    Sent from my iPhone using pure magic

  3. #3
    Join Date
    Jan 2002
    Location
    southern IL
    Posts
    1,886
    I left out. Level 7 bolt. So even less potentials. It will not fire with the barrel off. Stiff smooth trigger pull. But no air down the barrel. No click of the sear locking the bolt back in place. Nothing. I really wish it had a factory adjustment nut on the back. Because I halfway wonder if the aftermarket piece doesn't have something to do with it. Not letting the velocity to be turned up. I just don't remember to many companies in the past making upgrade parts that were worth a crap. But even with that. I would think the bolt would spit forward some?IMG_20130305_214229_047.jpg this is the adjustment nut that I am talking about.

  4. #4
    Join Date
    Jan 2002
    Location
    southern IL
    Posts
    1,886
    Humor me someone?

    If you take the velocity nut off the back of the regulator. Pull the spring pack out. And use a small rod or something to push in on the regulator piston. How far can you push it in by hand in this manner? I ask because I can only push mine in 1/16 or so. Shouldn't this be able to push in farther than that?

  5. #5
    Well, I didn't unscrew my reg nut since I just barely set my valve up/velocity... but if I unscrew the reg back and push the pin down to about where it should be seated, it travels about 3/16" past where the reg seat is... could probably go more but that's about where it feels like its going to stab thru my finger

  6. #6
    Join Date
    Jan 2002
    Location
    southern IL
    Posts
    1,886
    Well the pin moves freely in and out. I'm just wondering if I can't bump the velocity on that reg up enough to actually fire. I'm stumped here. I would swear the sear just isn't moving enough to unlatch. But I've gone over that so many times my head hurts.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •