Results 1 to 18 of 18

Thread: Flatline 4500 Questions

  1. #1

    Flatline 4500 Questions

    SO, I just bought a Flatline 4.5k that is currently attached to an in-hydro 72/45 PMI tank. The seller says it needs a rebuild though, and included a rebuild kit.

    I however have NO idea how to go about rebuilding it... Do i need to remove it from the tank? how would i go about doing that? How similar is the process to the 3k rebuild here: MCB 3k Flatline Rebuild

    Any help would be appreciated.

  2. #2
    Join Date
    Jan 2008
    Location
    central pa
    Posts
    64
    The guide on mcarter brown is great, also there is a sticky in the maintenance section that covers it, too. They are very similar to the 3000 psi units. Did the seller include a new reg seat or seal? It the red washer looking thing with a tapered hole in one side? if not, good luck finding one, thy dont make then anymore.

    Sent from my iPhone using pure magic

  3. #3
    Join Date
    Jan 2008
    Location
    central pa
    Posts
    64
    Found the sticky. http://www.automags.org/forums/showt...threadid=14220

    Sent from my iPhone using pure magic

  4. #4
    Join Date
    Oct 2006
    Location
    Houston, TX
    Posts
    3,181
    Pics help too. Put this together with 'Needa's

    http://www.warpig.com/paintball/tech...ne/index.shtml

  5. #5
    he said: "The Flatline needs a rebuild (rebuild kit with a new valve seat will be included , just not pictured)." So, I'm hoping that covers anything I would need. Seriously nobody fabricates these privately? that surprises me.

  6. #6
    Also, I DON'T have to take the tank off the regulator to access the internals? Just curious based on the thread from 2001 w/ the broken pic links.

  7. #7
    Join Date
    Jan 2002
    Location
    southern IL
    Posts
    1,801
    Quote Originally Posted by warchild69 View Post
    good luck finding one, thy dont make then anymore.

    Sent from my iPhone using pure magic
    dumb question due to this quote. I also have a 4500 flatline. If they don't make this part anymore. Doesn't that basically make the whole valve bad if that seal goes out? And inherently junk since a replacement can't be bought?

  8. #8
    Join Date
    Jan 2008
    Location
    central pa
    Posts
    64
    I don't know the right answer to that question, however, I have a 4500 and I have used a reg seat from a classic valve on mine, I know that's no the right thing to do, but mine has been working without leaks up to about 1100 psi. Definitely not a permanent fix, but it has got me through a pinch until I can find a suitable replacement. And I'm warning now,I dont condone using this method, but if you do, do so at your own risk. And if anyone comes across any, please share the weath!

    Sent from my iPhone using pure magic

  9. #9
    Join Date
    Jan 2008
    Location
    central pa
    Posts
    64
    Quote Originally Posted by Tylerjvan View Post
    Also, I DON'T have to take the tank off the regulator to access the internals? Just curious based on the thread from 2001 w/ the broken pic links.
    You have to remove it completely to rebuild it completely, but you can rebuild half the valve while its on the tank.

    Sent from my iPhone using pure magic

  10. #10
    Quote Originally Posted by warchild69 View Post
    I don't know the right answer to that question, however, I have a 4500 and I have used a reg seat from a classic valve on mine, I know that's no the right thing to do, but mine has been working without leaks up to about 1100 psi. Definitely not a permanent fix, but it has got me through a pinch until I can find a suitable replacement. And I'm warning now,I dont condone using this method, but if you do, do so at your own risk. And if anyone comes across any, please share the weath!

    Sent from my iPhone using pure magic
    How long has that been working? Notice any change in performance?

  11. #11
    Join Date
    Jan 2008
    Location
    central pa
    Posts
    64
    It's been working for a couple weeks, I can't go much above 1000 psi or it will start to vent thru the adjustment hole. Currently I'm looking at alternative washers. Hopefully I can find something that will work.

    Sent from my iPhone using pure magic

  12. #12
    Quote Originally Posted by warchild69 View Post
    It's been working for a couple weeks, I can't go much above 1000 psi or it will start to vent thru the adjustment hole. Currently I'm looking at alternative washers. Hopefully I can find something that will work.

    Sent from my iPhone using pure magic
    if you do, post it up here. I had another idea though, maybe a custom run of these from an overseas manufacturer? It would have to be done in BULK, but could be doable through the power of AO/MCB. lol.

  13. #13
    Join Date
    Jan 2008
    Location
    central pa
    Posts
    64
    Was thinking of that as well, I'll have to do some research on that as well. Keep me posted if you find anything too.

    Sent from my iPhone using pure magic

  14. #14
    Quote Originally Posted by Tylerjvan View Post
    if you do, post it up here. I had another idea though, maybe a custom run of these from an overseas manufacturer? It would have to be done in BULK, but could be doable through the power of AO/MCB. lol.
    Hey Tyler, if you want to try using classic valve seats, I'm pretty sure I have a couple extra kicking around I can throw in with the parts kit. It would save you the hassle of making an extra order and also possibly save you from potentially wasting probably the last 4.5k flatline valve seat in existence, lol.

    As far as reproducing these, I would give this company a shot : http://www.marcorubber.com/orings.htm . I've bulk ordered standard o-rings from them in the past and they do custum runs of non standard o-rings. Despite their web page being outdated, I do believe they are still in business .

  15. #15
    Yes, please do if you can find them, I'd greatly appreciate it. and i'll look into the company you suggested, thanks.

  16. #16
    BTW, anyone know what the original seal is made of? Urethane maybe?

  17. #17
    Join Date
    Oct 2006
    Location
    Houston, TX
    Posts
    3,181
    Quote Originally Posted by Tylerjvan View Post
    Also, I DON'T have to take the tank off the regulator to access the internals? Just curious based on the thread from 2001 w/ the broken pic links.
    Are you not getting the warpig pics? The reg hasn't changed since then and the pics are there.

  18. #18
    Quote Originally Posted by Spider-TW View Post
    Are you not getting the warpig pics? The reg hasn't changed since then and the pics are there.
    no, i see them. Just the guy who rebuilt one of the 3k on MCB had the whole thing disassembled.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •