Results 1 to 3 of 3

Thread: Emag valve. On off pin keeps sticking WAY out after degassing.

Hybrid View

  1. #1

    Emag valve. On off pin keeps sticking WAY out after degassing.

    So, if anyone remembers my travels through "buying a used emag" land, I finally bucked up and bought the pin, rebuild kit, and battery from Tunaman (thanks!). My baby works! In mech, in electro, the whole nine yards.

    Now, the idiot I bought it from messed with everything. Even just had to extend the sear rod that goes to the mech trigger to make it so the bolt doesn't stick after two shots. Think I got it right, might be a little too long. But that's not the issue.

    After degassing the damn on/off pin sticks like WAY out. It's even further out than if I take the whole assembly out and push the pin down to the top of the assembly, if you can understand my illustration.

    What could be causing this most unfortunate event?

  2. #2
    Join Date
    Dec 2000
    Location
    offshore
    Posts
    7,226
    You need to have the trigger rod length set correctly, then put it in Mech mode and pull the trigger before taking the valve out. This will set the pin in the on/off so you can pull the valve.
    Email me for low prices on ALL AGD Products and more. tunaman5@verizon.net
    Tunamart

  3. #3
    If you have calipers, here's the correct specs (from the sticky thread):

    Trigger Rod: 2.125"

    Solenoid Plunger Rod: 3.005"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •