Results 1 to 15 of 15

Thread: Reviving an Emag.

Hybrid View

  1. #1
    Join Date
    May 2004
    Location
    Arizona
    Posts
    193

    Reviving an Emag.

    So my Emag has been down for a few months, sitting in my Arizona garage.
    I gas it up and it vents out the back of the valve and down the barrel. It has the standard Emaxx valve, level 10 and a yellow LED display.Thats about it when it comes to fancy stuff.

    Where should I start? I rarely take apart my mag stuff so it's a new adventure each time I open one up.


    Thanks!

  2. #2
    Do a valve disassembly and reassembly, replacing any o-rings that have gone bad (nicked, dried out, cracked, gone to ooze, whatever) and then if you still get venting out the back, turn down the velocity until it stops. Then chrono and see where you're at. From that point, it may be fixed or maybe not, but you won't know what else needs to be done until that's all been done.

  3. #3
    Join Date
    Feb 2012
    Location
    Central Ohio
    Posts
    400
    And be sure to update the thread with what you have done and noticed until fixed. Justus just summarized everything you should do pretty well.

  4. #4
    Join Date
    May 2004
    Location
    Arizona
    Posts
    193
    Well I've never taken the valve apart. Anything I should know/watch out for?
    I'm sure I have part of a rebuild kit around here somewhere.

    And thank you, I'll give it a go when the garage is a little more bearable to be in.
    Last edited by PyroFiend; 09-18-2013 at 05:37 PM.

  5. #5
    Join Date
    May 2004
    Location
    Arizona
    Posts
    193
    So...I said screw it, my kitchen table became my new bench.

    Threw a towel down viola!

    Disassembled the gun down to reg, tube and bolt. Replaced an o-ring that had a neat cut on it, along the "perimeter" if that makes sense. Tossed some oil on there.
    No more leak out the back.
    However, leak down the front is very apparent.
    In Mechanical mode, if I hold the trigger down, the air flow stops.
    In Emode, it just leaks either way.

    I forget, is there supposed to be an o-ring between the bolt and the tube?

    Just found a crumpled note in my junk bit-o-pieces box that says "Thanks!" Me thinks my gun was fussed with by a friend.
    Last edited by PyroFiend; 09-18-2013 at 06:38 PM.

  6. #6
    Join Date
    Jan 2002
    Location
    Halifax, N.S., Canada
    Posts
    7,378
    The level 10 probably just needs to be tuned. Remove the shims and install the largest carrier size that doesn't produce a leak.
    Except for the Automag in front, its usually the man behind the equipment that counts.

  7. #7
    Join Date
    May 2004
    Location
    Arizona
    Posts
    193
    pulled out the one shim that was in the power tube. I'm trying to remember if that little brass piece in there is critical for barrel leaking.
    I appreciate your guys patience with this, it's been a VERY long time since I've opened it up.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •