Results 1 to 26 of 26

Thread: Detents, Detents, Detents... Having issues... Help.

Hybrid View

  1. #1

    Angry Detents, Detents, Detents... Having issues... Help.

    Okay...

    Let me take a deep breath before I end up getting ticked off.

    My Automag, since the day it arrived, has shot out every single detent I've installed. No matter how far I screw it in, it gets shot out. No matter how many o-rings I put over the detent to give it adequate spacing, it always gets shot out. It's getting old. Really old. Especially when detents run about $10 each.

    I'm coming up on my eighth detent...

    Help!

  2. #2
    Join Date
    Oct 2001
    Location
    New Jersey
    Posts
    822
    that's interesting, since i have never shot the original one that came with my ULE body for many years and cases of paint.

    but some questions:
    1) though, you should give a little leeway for the detent, it shouldn't be in as far as the screw hole will go, as it will physically effect the bolt. with that, is the body clean or has it been reanno'd?
    2) are you using angel-threaded detents right?
    3) have you tried a combo of oring AND some thread locker?
    4) are you running 1 or 2 detents?
    5) this is a ULE body correct?
    6) are you running a L10?

  3. #3
    Quote Originally Posted by Nobody View Post
    that's interesting, since i have never shot the original one that came with my ULE body for many years and cases of paint.

    but some questions:
    1) though, you should give a little leeway for the detent, it shouldn't be in as far as the screw hole will go, as it will physically effect the bolt. with that, is the body clean or has it been reanno'd?
    Body is clean, and has not been reanno'd.

    2) are you using angel-threaded detents right?
    Correct.

    3) have you tried a combo of oring AND some thread locker?
    Yes, and I'm using BLUE thread locker.

    4) are you running 1 or 2 detents?
    Using 1 detent. The last thing I need is to replace 2 detents instead of 1.

    5) this is a ULE body correct?
    Correct.

    6) are you running a L10?
    Correct. X-Valve.
    .

  4. #4
    aren't there long ones and short ones? I bought the long ones by mistake once, they are both Angel threaded

  5. #5
    Join Date
    Oct 2001
    Location
    New Jersey
    Posts
    822
    good point, there are long and short angel detents.

    other than actually going with a purple or a red loctite, i really don't know. this is a conundrum.

  6. #6
    Well, I suppose it is what it is. I've tried trial and error, and nothing's worked. I'm currently trying to order some detents from the company the makes the Sub-zero feedneck, so hopefully those should work a bit better.

    These are the detents I'm currently using.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •