Results 1 to 3 of 3

Thread: strangest leak ever

  1. #1

    strangest leak ever

    So I got my Logic frame back from Caustic Customs and had to install a trigger pin for the very first time- no idea how to do it. I set the frame on the top of a vice with a paper towel and pounded one side of the trigger pin with a hammer, also covered with a paper towel so that I would not scratch the anno. It appeared to work, but I'm worried that I bent the trigger pin inside or something, because the next day on the paintball field, the strangest thing happened....

    (Build: All mechanical, X-Valve Level 10, RT ON\OFF sized perfect by Roman at AGD, SHP Ninja Tank 1200 PSI, VD Rail, Logic Frame with fresh anno, Carbon Fiber ULE body.)


    So everything was fine. Chrono was about 265 and jumping about 5-7 each way, about 55 degrees outside. The RT effect was controlled and working great on the sweet spot, shooting like an arrow.


    A few hours into the day, when the temperature started to rise to about 85+ degrees, a small leak started out of the back of the valve which had a typical air leaking sound.

    I've never had a leak out of the back before. I ignored it.

    But then, a second sound started. It was a high pitch hiss, that almost sounded electronic, and the pitch of the hissing started to increase to a higher and higher tone, as each few seconds would pass, almost as if the gun was going to explode when the tone reached the end of the scale. Pulling the trigger temporarily ended the hiss for about 15 seconds. The weird hiss would then start again. And the longer I waited to fire, and the higher the pitch of the sound - the hotter round would shoot. At the highest pitch, the MAG would jerk back with recoil, guessing upward of 300, and make a much louder pop. The balls would shoot across the entire paintball field straight.

    If I shot too early, before the hiss was really squealing, the balls would shoot low.

    My MAG needed to charge-up for each shot!

    After I cleaned and oiled the valve that night, this all disappeared.
    Last edited by djinnform; 11-03-2013 at 10:42 PM.

  2. #2
    Join Date
    Oct 2001
    Location
    New Jersey
    Posts
    833
    this is a common occurrence that you had a speck of dirt in the on/off. it wasn't shutting off the flow of air(which results in air coming out the back. on a classic valve, you would get air out the back, and you would need to clean the reg seat). the high pitched leak, could be dirt, pinched on some orings, that caused the whistling. because of the leaking, the reg wasn't shutting off, resulting in the hot shot and conversely the dump chamber wasn't filling.

    though the oil "fixed" the problem, i would disassemble the valve, clean and clear any possible gunk and or dirt. its better to be safe than sorry, or get a hot gun penalty.

  3. #3
    Join Date
    Jan 2002
    Location
    Halifax, N.S., Canada
    Posts
    7,238
    That leak out the back would be caused by dirt or a bad spot on the regulator seat oring. Since a cleaning fixed it, it was probably dirt related. Give the valve a good thorough cleaning when you get a chance.
    Except for the Automag in front, its usually the man behind the equipment that counts.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •