Results 1 to 8 of 8

Thread: RT on/off and a Classic valve.

  1. #1
    Join Date
    Nov 2010
    Location
    Vancouver BC
    Posts
    48

    RT on/off and a Classic valve.

    I have a R/T on/off and would like to put it into a classic valve with a level 10. Is there anything I will need to do
    to ensure proper function?

    Thanks in advance.

    SZ
    Quote Originally Posted by going_home View Post
    This is AO, find/make/mod an alternative .

  2. #2
    Join Date
    Oct 2001
    Location
    Plymouth, WI
    Posts
    7,198
    Yes. Take the classic on off out first.

    To leave feedback: Click seller/buyers name, Click feedback score, Click leave feedback

  3. #3
    Quote Originally Posted by BTAutoMag View Post
    Yes. Take the classic on off out first.

  4. #4
    Join Date
    May 2002
    Location
    West Coast
    Posts
    3,721
    Quote Originally Posted by BTAutoMag View Post
    Yes. Take the classic on off out first.
    Now thats funny.

    But seriously... to answer your question. It will work, but you'll suffer from short stroking and with the LVL10 it will be even trickier to get full shots at rapid firing. If you are using a mechanical trigger then you need to make sure you fully pull the trigger back and let it go all the way forward. It will make the trigger lighter and have a very small RT feel, but I doubt you'll like it. Give it a shot and see if you like it. Post up your results.

  5. #5
    Join Date
    Nov 2010
    Location
    Vancouver BC
    Posts
    48
    Quote Originally Posted by Sk8ermog View Post
    Now thats funny.

    But seriously... to answer your question. It will work, but you'll suffer from short stroking and with the LVL10 it will be even trickier to get full shots at rapid firing. If you are using a mechanical trigger then you need to make sure you fully pull the trigger back and let it go all the way forward. It will make the trigger lighter and have a very small RT feel, but I doubt you'll like it. Give it a shot and see if you like it. Post up your results.
    Would it work better with a Level 7?

    SZ

  6. #6
    Join Date
    Oct 2013
    Location
    Dayton OH
    Posts
    461
    i didn't notice any issues with my rt on/off and lvl 10 / 7 setups.

    aren't you supposed to use a shorter on/off pin (standard length is .750)? the pin in my rt on/off is .745 for whatever that's worth.

  7. #7
    Join Date
    May 2002
    Location
    West Coast
    Posts
    3,721
    Quote Originally Posted by Cyco-Dude View Post
    i didn't notice any issues with my rt on/off and lvl 10 / 7 setups.

    aren't you supposed to use a shorter on/off pin (standard length is .750)? the pin in my rt on/off is .745 for whatever that's worth.
    A shorter pin could help. I'm just talking from personal experience that I've not been able to get a RT on/off to work well in a classic valve and a mech frame. I have had great success with a RT on/off and a hyperframe on a classic valve.

    A LvL7 might also help a bit too, but just like all mags you will need to test things out because each valve can be a little different and can act differently. Try it out and see what happens.

  8. #8
    Join Date
    Sep 2008
    Location
    Ohio
    Posts
    4,508
    I have to admit, I have two on/offs in two Classic valves. Neither is L10, one is a pump and one is a pneu frame. Both seem to work fine, but I don't actually have one in a mech frame.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •