Results 1 to 4 of 4

Thread: Classic valve not firing

  1. #1
    Join Date
    Feb 2012
    Central Ohio

    Classic valve not firing

    I'm trying to make this quick and simple, usually I'd rather go through the usual abyss of information at my hands here but I just wanted to make this quick and clean. Anyways, here is the situation.

    My setup
    Classic valve
    Level 10
    Minimag main body with a Noxx clip welded on, converted the marker to a pistol
    Basic AM/MM lowers (standard rail, grip, etc..)

    Air system
    A 1/8th brass piece connected to an ASA+12g changer directly off to the side of the marker. This is run off of 12 gram CO2 cartridges.

    My issue:
    Simple, the gun pressures up and hold pretty well, but I pull the trigger and it doesn't fire. Yes the trigger bounces back. The breach is clear, I am attempting to dry fire. Does not work.

    I know I've heard/had this issue before although I forget how I resolved it. I adjusted the velocity from all the way in, to as far back out to where it began to leak out the back. All the while attempting to fire Inbetween and still no luck. No I have not oiled it yet, I seem to have misplaced it. This all worked just fine last time I used it (back around October/September) but I was using HPA via remote line back then instead too, but the trigger rod seems to be in place although I have never adjusted it.

    I'm hoping this will just need some oil but just in case that doesn't turn out to be it then I'd like to have this for a quick reference. What else could it be?

    Appreciate any help and advice.

  2. #2
    Join Date
    Oct 2013
    Dayton OH
    velocity not high enough / pressure not high enough. this doesn't seem to be it though?

    sear rod it too short? if it's too short the sear won't disengage from the bolt.

    some other kind of mechanical interference that is preventing the bolt from cycling smoothly. try a different body if you have one. is the frame screw too tight? is the field strip screw too tight / loose? take the valve and barrel out. take the bolt off and insert it into your barrel...does it fit? the lvl 10 bolt may need to be filed / sanded down to fit into smaller bore barrels (.685 for example).

    is the lvl 10 o-ring carrier too tight? i would first try oiling it (find that oil, man!) and see. with the valve out and held upright, the bolt should sit on the o-ring, but fall down with a gentle bump on the bottom of the valve. tight enough to seal, but not so tight you get bolt stick.

    i'm sure athomas will have better insight; these are the things that i can think of off the top of my balding head.

  3. #3
    Join Date
    Jan 2002
    Halifax, N.S., Canada
    The info given above is pretty much spot on. You shouldn't have to worry about field strip screw tension on a minimag body though. That generally only occurs with the aluminum bodies. They have a tendency to flex more.

    Take the barrel out of the body and see if it cycles without the barrel. That will eliminate the barrel from the equation. Are you using the stock velocity adjuster or an aftermarket velocity adjuster? Sometimes the aftermarket ones are too deep and don't put enough tension on the spring pack to get a high enough pressure to fire the gun.

    If you are not already using it, try putting the short gold spring on the bolt. That one will allow you to operate at the lowest pressure setting, which should get the gun cycling, even if it is a pressure or force issue.

    Make sure the sear pin is fully snapped into the rail. Make sure the rail bushing is in place as well.
    Except for the Automag in front, its usually the man behind the equipment that counts.

  4. #4
    Join Date
    Feb 2012
    Central Ohio
    Hey guys. Took her out today and gave her plenty of oil and boy was she thirsty. Got ahold of some good oil, took her apart and did a good check/tune up. Gassed her up and she worked like a charm.

    Thanks guys!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts