Page 3 of 3 FirstFirst 123
Results 61 to 70 of 70

Thread: Evo Body back from anno

  1. #61
    you can remove the toolmarks on your own, no need to get charged 100 dollars, go to home depot and spend like 20 bucks on some sandpaper and scotch brite, put on a movie or some music and give it some elbow grease

    or I'm sure Simon would have let you use the tumbler Scott, that's what I did with the Nocturnal rails I had, makes polishing them super easy, the anodizer loves you for it because it makes polishing go super fast.

    edit: jesus, some of those are pretty...pronounced, better make that a few movies
    CNC Programmer/Machinist
    Polarstar Engineering and Machine

  2. #62
    Join Date
    Oct 2001
    Location
    Inception Designs HQ
    Posts
    2,324
    Quote Originally Posted by ElPanda View Post
    you can remove the toolmarks on your own, no need to get charged 100 dollars, go to home depot and spend like 20 bucks on some sandpaper and scotch brite, put on a movie or some music and give it some elbow grease

    or I'm sure Simon would have let you use the tumbler Scott, that's what I did with the Nocturnal rails I had, makes polishing them super easy, the anodizer loves you for it because it makes polishing go super fast.

    edit: jesus, some of those are pretty...pronounced, better make that a few movies
    Justin, Simon had already seen it and said it would loose too much detail in the tumbler.

  3. #63
    Join Date
    Feb 2005
    Location
    Soon to be the Dirty jErZ
    Posts
    8,915
    Mario from Fx was good enough to give mw detailed information and info. After 20 mins I said f it and sent it to him.

  4. #64
    Join Date
    Mar 2002
    Location
    VA
    Posts
    2,656
    Have we isolated this issue yet? I just sold off my Evo body, but if I remember correctly it did have a channel. Does anyone else have this issue or was this a one-off issue?

  5. #65
    Join Date
    Dec 2004
    Location
    Tampa, hot & humid.....
    Posts
    7,116
    It has the channel but the valve won't spin far enough to get the thumb screw in.

    Just glad he posted this thread before I had it anodized.

    "When injustice becomes law, resistance becomes duty." Thomas Jefferson

  6. #66
    Join Date
    Jun 2007
    Location
    If you want peace, prepar
    Posts
    1,715
    Mine fits but is tight. Only tried it with one x-valve

  7. #67
    Join Date
    Oct 2011
    Location
    Sunny, England
    Posts
    441
    I've tried 3 different ones and all have been fine, definitely worth checking before any anno work is carried out,

    I also got mine anodized before I checked though.

  8. #68
    Join Date
    May 2004
    Location
    Schenectady NY
    Posts
    492
    Just checked. Have some work to do

  9. #69
    I bought one from Renie and had 2 different xvalves in it without problems. May have been an error on some bodies.

  10. #70
    Join Date
    Nov 2016
    Location
    CT
    Posts
    52
    I still own it dano_____. Make that 3 Xvalves without a problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •