Results 1 to 8 of 8

Thread: regulator piston problem and thoughts

  1. #1
    Join Date
    May 2018
    Location
    SWEDEN
    Posts
    18

    regulator piston problem and thoughts

    got hold on a couple non funktioning almost complete automags that needed some love and care that got build together as a minimag pistol.

    but heres my question... had some isues with fluxing velocity over crono and checked the regulator piston oring surface and found that it is somewhat irregular in surface like streaks frome lathe machining and checked at my working mag and found out that it too had slight irregular surface where velocity piston is seated but it works for that valve but caught my attention when two valves got the same type of streeking ore if this is a normal thing that other had stumbled upon also?

    so is it just me that thought it should be smoth surface for the regulator piston oring ore is this a common thing and nothing to worry about?
    Paid in paintballs

  2. #2
    Join Date
    May 2018
    Location
    SWEDEN
    Posts
    18
    lots of views but no answer

  3. #3
    Join Date
    Dec 2000
    Location
    offshore
    Posts
    7,847
    Quote Originally Posted by SWE HooK View Post
    lots of views but no answer
    are you talking about the inside of the valve half where the reg piston oring rides? Or on the piston itself? If so, in all my years of teching these mags I have never run across one that didnt seal there...or needed attention there. You can always polish it if that would make you feel better.
    Email me for low prices on ALL AGD Products and more. tunaman5@verizon.net
    Tunamart

  4. #4
    If something is scoring the piston, that's a problem. The o-ring is what makes the seal and the springpack is what will have a bigger impact on velocity consistency, but if there's enough junk in there that the piston is getting messed up, then you definitely need to clean out the reg back and re-grease everything.

  5. #5
    Join Date
    May 2018
    Location
    SWEDEN
    Posts
    18
    Quote Originally Posted by Tunaman View Post
    are you talking about the inside of the valve half where the reg piston oring rides? Or on the piston itself? If so, in all my years of teching these mags I have never run across one that didnt seal there...or needed attention there. You can always polish it if that would make you feel better.
    yes its on the inside the regulator where the reg pistin oring rides.
    its not that it aint seling its not leaking but as mentiond i got some sporadic fluctuation over crono and got picky in mu serch for an explanation and found on two valves with different numbers with smal rifeling from the lathe process from manufacturing.

    my next theory is that my regulator on airtank is the problem by leaving fluctuation in air pressure and therfore upsetting the regulator in the automag valves.

  6. #6
    Join Date
    May 2018
    Location
    SWEDEN
    Posts
    18
    Quote Originally Posted by bowcycle View Post
    If something is scoring the piston, that's a problem. The o-ring is what makes the seal and the springpack is what will have a bigger impact on velocity consistency, but if there's enough junk in there that the piston is getting messed up, then you definitely need to clean out the reg back and re-grease everything.
    its probably just me that is over picky on details this time... had got the regulator piston out a couple of times and cleand and greased it up so its clean and nothin to scoring the piston but there seem to be some rifeling from the manufacturing process in the surface that is sealing agaist the oring on the piston on two different valves that i in my search for a explanation to my problem with fluxing speed on crono had made sort of a tiny feather in to an ostrich and that my find is irrelevant to the problem but not to make a asumption i asked if ther is more that got the same "findings" in ther regulators.

  7. #7
    Join Date
    Dec 2000
    Location
    offshore
    Posts
    7,847
    Quote Originally Posted by SWE HooK View Post
    its probably just me that is over picky on details this time... had got the regulator piston out a couple of times and cleand and greased it up so its clean and nothin to scoring the piston but there seem to be some rifeling from the manufacturing process in the surface that is sealing agaist the oring on the piston on two different valves that i in my search for a explanation to my problem with fluxing speed on crono had made sort of a tiny feather in to an ostrich and that my find is irrelevant to the problem but not to make a asumption i asked if ther is more that got the same "findings" in ther regulators.
    I would be more inclined to replace the regulator seat...and then dont take it apart until something breaks. Everytime you unscrew the halves they do not wind up in the same place on the reg seat...causing fluctuations in velocity.

  8. #8
    Join Date
    May 2018
    Location
    SWEDEN
    Posts
    18
    Quote Originally Posted by Tunaman View Post
    I would be more inclined to replace the regulator seat...and then dont take it apart until something breaks. Everytime you unscrew the halves they do not wind up in the same place on the reg seat...causing fluctuations in velocity.
    that part i know not to take the halves apart when ther is a new regulator seat in, im just tinkering with regulator piston back at the velocity adjustment as ther where the place i asumed might be the problem and as stated ther might be problem with my botle to that might causing the problem.
    its just annoying not finding the problem and im start with wild speculating and finding a nonproblem and get stuck with that whilst ther might be a simpler explanation.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •