Page 6 of 6 FirstFirst ... 23456
Results 151 to 165 of 165

Thread: Offical LVL10, Reports from the Field Thread

  1. #151
    Join Date
    Apr 2002
    Location
    SoCal
    Posts
    1,737

    Re: Ahhh...Bliss!

    Originally posted by Bad_Knees
    Took about 10 minutes to install and 45 to tune.
    No. 2 Carrier
    2 Shims
    The spring that has one end cut
    no foamie
    Chrono'd at 273
    Didn't notice a drop in efficiency.
    Around 1000 rounds fired not one ball break.
    Using Cobra Eggs, Point Blanks, and All Stars.

    As the friend with micromag (mentioned in Gibby's post), I had absolutely no chops and enjoyed hammering the trigger. The RT valve responded well and the trigger has a nice crisp feeling to it.

    No more short stroking...no more breaks anywhere! It was a great squeegee-less night! Showed the people on the field what Level 10 could do, it definitely changed their views on Mags for good!
    Hi, I've heard a lot about you!! You have some pretty good predictions!!!

    Originally posted by Miscue
    Romeo... bah! He's a pathetic fool who was lamely obsessed with the impressionable Juliet.

  2. #152

    Wink Hehe..

    Sorry to change the subject on the thread.


    Well I was just giving a third persons point of view...but it is nice that these things have happened for two very special people...I wish them both the best

    BTW I need a pic of the both of you in jerseys. Maybe you should have had just arrows on them saying "He's following me" and "I'm lost without her"...LOL

  3. #153
    Join Date
    Jul 2002
    Location
    Sandy Eggo, by way of Mobtown
    Posts
    11
    Just reporting on another day with my level 10 automag

    went through a case and a half of Big Ball yesterday. I had 1 break in the chamber. The first such with the level 10 in my automag . . . and I've gone through about 5 cases of paint so far.

    But, here is what happened. My 12v revolution hopper died at the start of the game. Electronics in it melted down - the batteries were HOT when I popped them out. So I was pissed (the revvy is only 2mos old) and to keep playing I wasn't satisfied to just shake the gun frequently. I had to start hitting the hopper and smacking it into barricades. I think I cracked a ball inside it that way that once it fed down it just went in the chamber. With the gun gooed at that point I went back to just shaking it to get the hopper to feed. And I also fanned the trigger the whole rest of that game. No more breaks, but a whole lot of the bolt venting and resetting.

    The setup again on my R/T valved automag. 1.5carrier, 2 shims, medium length spring. Shoots ~290's consistent with proper paint.
    I don't believe it, its that *****box dodge again!

  4. #154
    Join Date
    Feb 2002
    Location
    Austin, Tx
    Posts
    102
    Mine took maybe a hour to put in, and fine tune with diffent on/off pins etc. Efficiency has dropped of a little, though consistancy across the chrono is great +/-3 fps. Accuracy has also improved 10 fold. 0 breaks with various paint for 1500 rounds. This is on an RT Pro with 12" Boomstick.

    I went out to a field for the first time, and seemed to be the only player with a Mag amoung to sea of Cockers and a few electros (Imps). The ref looked at my gun and said wow a RT those are sweet guns when they don't chop. So I handed it to him, and told him to rip on it. He did just that, paint was flying faster than I had ever seen before. He handed it back and said dang I figured it would chop. Once he found out it had the LVL10 inside it was all over. Everyone from the owner to a guy with a Vision Imp where drooling over it, and playing with it. Damn I love my RT.

  5. #155
    Join Date
    Sep 2001
    Location
    Bethany , WV
    Posts
    11

    Talking Woo hoo! I got one to break!

    Got the level 10 installed:

    I'm shooting a ReTro Minimag w/ Intelliframe.

    Using Middle Spring, 2 Shims, 2.0 Carrier.

    Works well. I shot ~200 rounds of field paint to test and then some paint that was 1 and 1 1/2 years old (and poorly kept btw). The Level 10 held up on it's promises - even allowd me to shoot at a 90 degree angle for several rounds - resetting on every other shot of course. I DID manage to break one ball though - with the 1 1/2 year old stuff I was able to get a break after hitting it about 8 - 9 times directly on the seam of the ball (which was where it cracked open btw).

    So over all - I am very pleased. Accuracy seems to be the same. It's much more gentle on paint. Diggin' the foamie (someome shoulda come up with that years ago... )

    Only concerns I have are in the the departments of efficiency, tank pressure, and RT Reactivness. Currently I run a cheapo 68ci 3000psi PMI Pure Energy tank. I think it's preset at 800 psi, but don't quote me. Great tank for the stock Minimag. No too sure about it now with the Retro/Level 10 combo. I don't seem to be getting great reactivity in the trigger anymore (something several other users have noticed, but that might just be my perception as well) and my efficiency is significantly less - I'd say I might be able to get something less than 600 good shots with it. Maybe it's just time to upgrade my tank to something a little more sexy, but I did want to forward along my observations reguarless for anyone that may be in the same position.

    Great product, I can't wait to get it on field to play some serious 'ball with it. Thanks!

  6. #156
    Join Date
    Aug 2002
    Location
    oceanside
    Posts
    50

    OMG. This is the best design ever THANKS MUCH AGD

    This is about the greatest thing to come along besides the automag. Set up time was minimal apx 10 min. Tweaking takes about 500-1000 dry shots. The carrier that you use that doesnt leak will more than likely leak after it breaks in the teflon oring. Downsizing the the next carrier or two (but still use the same teflon oring from the orginal carrier!!!!)will correct the situation. Tom you need to give me some other ideas MY MAG IS MAXED OUT. I have been using a mag for about 7 years now. Wouldnt trade for anything else. Its cool being the black sheep of the group seeing all autocockers and angels and whooping some butt with the proven old school gun. Thanks TOM and AGD Team. Keep the MAG ALIVE

    BTW. I forgot to mention on downside (which is a minor thing) There is about 500 psi in the gun after airing down. (shutting of the air supply but still attached to the gun)

    Is it the retro valve or lvl 10 that doesnt allow an additional shot to release all pressure from the gun???.blown orings on tank frequently. I have a ungodly large 32 degrees slide check (without quick disconnect, not needed) on the gun now to correct the situation. T

    The macro lines I have set up run from the retro valve to the drop foward and on the drop foward is where the slidecheck is. and then the macro fitting is attached to the slide check and runs to the drop foward. What this allows me to do is bleed the tank and allows for removal after removed i can slide the check back to release the air still in the retro valve. Cant find ANS micro slide check anymore???? Any other ideas or future products to correct this???[IMG]http://[/IMG]
    Last edited by midnightcharger2; 08-31-2002 at 02:50 PM.

  7. #157
    Join Date
    Aug 2002
    Location
    Palisade, Colorado
    Posts
    86

    lev10 upgrade

    The lev6 standard mag is the first gun I bought many years ago and it was great. guys used to run from me cause i could shoot so fast. then i started playing tournaments. gun froze up first game and i went to high pressure. got by with that and numerous other upgades. Barrels, Loaders, new frame, double trigger, you know the story. then i started chopping balls. every game same story. so i bought an angle. awesome gun. then came the lev10. i had some problems getting it to work following the step by step instructions. what it came down to was i had to get a new on/off valve and once i put that in it worked perfect. i shot some 2 year old paint, big ball that would break if you dropped it from 3ft off ground. not one single break. this upgrade is awesome accomplishment and if it had been on the market 4yrs ago i never would have bought another gun. i think the lev10 bolt should be standard on all mags. but i guess if you don't shoot fast then you don't need it. i don't see how you can compete without it.

  8. #158
    Join Date
    May 2002
    Location
    Boston, MA
    Posts
    2,105
    I'm using a minimag with a level 7 valve, just got the level 10 installed (2.5 carrier, 3 shims, shortest spring), and all I can say is...wow! I stuck my finger in it, and it was a little more powerful than I expected (I definitely wouldn't stick my tongue in there! ), but I've shot some rounds through it and it's definitely soft on paint! Works wonders. The only thing I don't like about the level 10 is the fact that I need to turn up my velocity/reg pressure so it works.... oh well. Great work AGD!

    Good Traders: SupaTravis, Joeyjoe367, biker, Zenwood, arabian ape, beefstew, timmy63, ah137, kilaueakid, Will Wood, Remington, DicksonDood23, CPhilip, Fritzy, Dirtybunny, LittlePaintballBoy, JadedT, ChucktheMAGician, TheFlamingKoosh, lgavin
    My Feedback Thread
    Out of the sport... missing it.

  9. #159
    ryan17 Guest

    Thumbs up

    Installation-Came with my Extreme E-Mag

    Efficiency- I was able to shoot 2 pods and a hopper in RT mode. With about 800 psi left on my 68/3000.

    Never Choped, just bounces off paint, I was in a tourny shot PMI premium, 2 cases, not one chop, it's almsot impossible with the ACE in it.

    I love it, great upgrade if don't have it already.

  10. #160
    Join Date
    Jan 2003
    Location
    TX
    Posts
    1
    how long it took to install....

    Hmm ok. Well i work at a paintball store. And i had great hopes of becoming a tech. Aint gonna happen. Got the kit and the first day, i spent the entire time trying to figure it out. No dice. Next day picked up APG's magazine that gave instructions. AHHHH took 20 minutes. I have the 1.0 carrier with two shims and the stock spring. The stock spring wouldnt chop paint but kept the gun within 240 to 295 range whenever i wanted to change it. Still havent experimented with longer springs. No need.

    Tpye of gun...

    red splash minimag with ANS red anodized reg., ANS drop foreward. still waiting for my X valve

    Efficiency...

    noticed a little drop off but that could be due to the fact of the crowd gathering around me after every game to watch the finger test and the taped ball test. Had em all going nuts over it. So a lot of air went to dry firing on my finger.

    Number of chops....

    HAHAHA none whatsoever. The day started out very cold then turned hot. Not good for paint. I truly believe i was the only one out there who didnt chop any balls. Total i shot 2 cases out of the gun. Some PMI premium 6 month old dimpled balls, old and new marbilizer, Evil, rec sport, and big ball. Didnt matter what kind of paint, no chops at all. Had some venting when i started hitting a big string of fanning the trigger but no chops. Had 2 marbilizers break about an inch before the end of the barrel but it was because the paint is so bad it was almost square shaped.

    problems encountered....

    Other than finding out the hard way that following instructions helps. After reading them the install took no time at all.

    other comments....

    My team is sponsored now by an autococker maker. Can't say who cuz i dont want to loose our sponsorship. But the problem is they were all choping balls today. Now with this new bolt i really dont want to use their gun. Ahhh what a dilema. Hey tom, wanna sponsor a team. Please.....i dont wanna stop using my mag now. Level 10 is amazing!!! Thanks AGD

  11. #161
    Join Date
    Feb 2003
    Location
    St. Charles, IL
    Posts
    75
    -How long it took you to get it installed

    I would say around 20-30 mins. but I was taking it slow making sure I had everything setup properly with the right fit.

    -What your configuration was to get it working properly

    At first I used a 2.5 spacer, 2 shims, and the middle spring. After firing it for a little bit the o-ring broke in and I developed a slight leak down the barrel. (this is normal and you need to move the next smallest spacer) I then went to a 2.0 spacer, 2 shims, and the middle spring and this setup has worked fine firing over 1000 paintballs.

    -The type of gun you're using it on

    My gun is listed in my sig.

    -Efficiency

    I can't really answer this since I have a 88 CI nitrogen tank and can easily go 3+ games without needing a refill but I would assume the efficiency is lower since you need to increase the pressure. This is the case because of the stronger spring and more force that is required to move the bolt forward.

    -Number of breaks/chops and type of paint used

    I tested the level 10 first in my backyard with the worst paint I had. I had some old paint from summer that I got at a field and never used all of it...this stuff was in a zip lock bag for close to 6 or more months and to top it off I think it was brass eagle. I loaded around 100 balls in my hopper and fanned the trigger. I short stroked at least 3-5 times distinctly hearing the bolt stop on the balls. I only had 1 ball that broke down the barrel and wasn't from the bolt.

    When I went to a field I shot over 1000 Diablo brand paint and only had 1 break down the barrel and that wasn't from chopping the ball. I assume it was because that particular ball either was cracked, had a defect, or expanded more than the others for a tighter fit down the barrel.

    -Any problems you encountered

    No problems so far and I have gone to the field 2 separate times. I shot at 258, 266, and 271 at the chrono with the setup the first time I went to the field. I had only 100 balls thru it and another 100 dry fires. I latter chronoed with a ref and got within 2-3 fps consistency after the setup had around 500 more balls thru it.

    -Other general comments

    The lvl 10 kit almost turns your gun into another. It makes chopping balls extremely hard and increases your performance because you can shoot faster without having to worry. I recommend getting this kit for anyone that has a mag. Before I had this kit I was consistently breaking a few balls if I needed to do a fast string of shots. You can almost leave your battle swap and jerk squeegee back with your tool kit.
    Camo Green MicroMag #CF33558
    lvl 10 kit on 68 Automag A.I.R. Valve
    16 in. Black Aluminum Freak w/ All American Tip
    Black Blade Intelliframe
    12v Revvy w/ TurboRev
    Nitro Duck 88/3000 w/ Centerflag Hyper Flow 301 Reg

  12. #162
    Join Date
    Jan 2003
    Location
    New Jersey
    Posts
    2,478
    -How long it took you to get it installed and what your configuration was to get it working properly

    5 minutes to set everything up, but after I aired up and started going I had to change carriers. Took a total of 45 minutes to oil it and shoot enough air through it so it ran nice and smooth

    -The type of gun you're using it on

    See sig, 2 shims, 2.5 spacer, med spring, couldn't get the long spring to work :/

    -Efficiency

    Less efficient than the Venturi bolt I was using before this, but barely

    -Number of breaks/chops and type of paint used

    Started out with brand new 1 week old Marbellizer (really good paint) shot half a case out of it, not a break anywhere (except on the guys on the recieving end)

    Then moved to some older no name white box paint... about 4 months old, been sitting in my closet for a while, used it for target practice, shot another half a case, not a single break or chop.

    -Any problems you encountered

    Since my gun has a warp feed on it once in a while it would pushing against the ball in the breach, putting enough pressure on the ball that the lvl 10 would bounce off of the ball and effectively not shoot. Problem was circumvented by simply ducking turning off the warp, loosening the tube allowing the balls to relax, resetup and fire. Only happend twice and towards the end there were no problems.

    -Other general comments

    Greatest upgrade ever made for the automag, makes the day so much less hectic!
    Rooster "But such is the mentallity of the Arab people. Which is why as long as there are Arabs, there will be a terrorist problem."
    ^^^ known AO racists


    Contact Info
    AIM: holsamoht
    e-mail: Thomas.Loh@gmail.com
    My Feedback

  13. #163
    Join Date
    Apr 2003
    Location
    California
    Posts
    6

    Level 10 Testing

    -How long it took you to get it installed and what your configuration was to get it working properly:
    It took me about 15 minutes to install it and one day of paintball to properly adjust my valve.

    -The type of gun you're using it on:
    Custom MiniMag w/ vertical feed, X-Valve (No. 2 Carrier & two shims), 4500 Flatline, Dye Titanium Barrel, Dye .45 Grip

    -Efficiency:
    Very efficient...all my shots were very consistant, very straight, and was able to shoot as fast as I wanted to after I adjusted it.

    -Number of breaks/chops and type of paint used:
    1000 rounds and one break (I was holding the gun sideways...so I believe the break was my fault and not the bolt). I was using Viper Paint/Venom Series

    -Any problems you encountered:
    After about 600 shots I was getting a leak down the barrel and is why I adjusted my gun after the first day. This leak is very normal and all I had to do was move to the next smaller carrier/spacer in my gun...I also added 1 shim. I also added the next size bolt spring since it is designed for 275-300 fps. After doing this I had to adjust my regulator to about 600 psi and tighten the valve about 3/4 full. Without increased pressure the gun will either not shoot or will not operate great at rapid fire. This is also very normal...just make sure you increase the pressure in the regulator.

    -Other general comments
    I will give another report after this weekend...but I think I will be able to shoot as fast as I want with same consistency.

  14. #164
    Join Date
    Jun 2002
    Location
    Fredericksburg, VA
    Posts
    430

    Talking

    I'd answer all the questions and make all the comments but I won't waste anyone's time. It's very simple. I have an XValve in my "stock" Mag and XMag sn#0109. I have never chopped a ball in either paintball gun in ANY situation, game or otherwise. Shots over the chronograph vary less than 10fps at all times and average + or - 5fps. Both are consistent, as fast as anything else on the market and extremely reliable. I have experienced no leaks or other problems of any kind. Long live Level 10, and long live AGD!
    Josh
    Joshua D. Silverman
    Vice President - Marketing, Adventure Beach Paintball, www.adventurebeach.com
    Sponsorship Coordinator/Media Liaison, CFOA www.thecfoa.com
    www.joshuasilverman.com

  15. #165
    it took me about 10-15 mins to install the lvl 10 (very easy to do). i installed it on a old 93 automag with double trigger and 68 3000ci nitro duck tank w/ old school venturi barrel. i tested it using both classic main body(straight non-powerfeed) and also on a teflon powerfeed. i didn't use my revi at all that day. i got about 800 shots off of my tank. ok here is the good part i had 1 ball break in 3 days using the classic feed and that was with a bad ball (it didnt chop though ) and i didnt chop one with the powerfeed. i was using pmi premium paint and also worr paint. the pmi was about 3-4 months old and worr brand new. i shot a total of 4000 balls(a case of each). i was easly able to get about 11 to 12 bps. this is the best thing to come out of AGD other than the mag itself good job guys and keep it coming.
    68 automag
    teflon powerfeed
    lvl 10
    venturi barrel
    68 3000 nitro tank
    double trigger
    custom drop forward

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •