Results 1 to 6 of 6

Thread: Emag Safety is real hard to make "safe"

  1. #1
    Join Date
    Jun 2001
    Location
    Bloomingdale, IL
    Posts
    1,263

    Emag Safety is real hard to make "safe"

    I can't push it in. When I finally get it pushed in it won't move back out. Is there a way to remove it and clean it or replace it or something? I'm thinking it's just dirty and needs some TLC.
    My Trader Feedback
    It was the only tournament I've been to where they have more cases of beer than paint. - gimp

  2. #2
    Join Date
    Oct 2000
    Location
    North Plains, OR
    Posts
    4,956
    Take off the mainbody and rail, lift the sear out of the way, and push the safety out from the "safe" side of the safety. There's a ball and spring on the "safe" side of the frame that will pop out once the safety is out of the way, so hold the frame over a towel when you push out the safety.

  3. #3
    Join Date
    Aug 2002
    Location
    Texas
    Posts
    14
    my emag has the very same problem. I have removed the safety several times and cleaned and oiled it, but it doesn't make any difference. I'm not sure what causes the problem.....right now, I just don't use the safety because once it is on, it's extremly hard to take off..cannot be done by hand.

  4. #4
    Join Date
    Jun 2001
    Location
    Bloomingdale, IL
    Posts
    1,263
    same here pool. I just tried cleaning it last night and it didnt' work to well. Was fine for a while and after a bit it went back to sticking.

    I messed up something on my board though i think so i have to send the mag in, I'm thinking ill just have AGD work on the safety when its in there.

  5. #5
    Join Date
    Jan 2002
    Location
    Halifax, N.S., Canada
    Posts
    7,380
    I put brand new springs and ball bearings and fresh lubricant in my safety and promptly got the safety stuck in the on position when I was testing it. I had to punch the safety pin out. It pushed the bearing out through the inside of the grip frame in the process. I don't use my safety any more because of this. I actually use the e-mode selector switch as my safety now. When the switch is fully back the trigger is held forward. The gun won't fire at all because I have the trigger magnet adjusted so it fires near the back of the trigger pull instead of the front.

    It works well and gives me a piece of mind knowing that I have a measure of safety. I still use a barrel condom though.

    AGD should revise how the safety works on an emag. I have seen this mentioned many times, so it is obviously a problem in the design of the safety. The overall concept of the sear lock is good. The implementation needs to be perfected.

    The problem is that the grooves cut in end of the safety pin to lock the pin in its position are too deep. Any grit or imperfection between the pin and bearing detent causes the pin to not be able to push the detent down. The side force on the bearing is greater than the down force. This can cause the bearing to not move down but to lock the safety in its present position.
    Except for the Automag in front, its usually the man behind the equipment that counts.

  6. #6
    Join Date
    Sep 2001
    Location
    Brussels, Belgium
    Posts
    377
    I had the same problem (in fact safety stuck in safe mode a few times).
    I've cut the small spring to reduce the force on the small ball, and put a lot of grease on the safety. It's a lot better now.
    Slightly alter the profile of the grooves on the safety pin can also help.

    @++
    Intimidator Shocktech with Technatrigger.
    AGD Emag Extreme C&C Lvl10 ACE.
    "Pandora, that is the FIRST C&C Extreme to ever be sold." Manike

    "Destruction and reckless abandon. And you all helped to create it!
    WAY TO GO!" The EVE Online Team

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •